Sökte, men hittade inget om installera .tar.gz2

Re: Sökte, men hittade inget om installera .tar.gz2

Inläggav Marie SWE » tis aug 21, 2018 1:49 pm

Mikael skrev:Inte meningen att märka ord, jag tror du har full koll på skillnaderna.
När jag svarar så försöker jag om möjligt ta med ett "allmänintresse" där andra som läser tråden om möjligt kan bli hjälpt.


Jag tror det finns några sådana trådar under http://linuxmint.se/forum/viewforum.php?f=29 ex. hur man installerar sk BUNDLE osv. men det kanske kan vara på plats med en sammanställning av olika metoder. Vi får se vem som orkar börja ;)


okej.. jag tror inte denna tråden hjälper någon, den är bara rörig o full av frustration från min sida*hahahaha* :lol:

Tackar, jag ska kika på länken när jag får lite mer tid att sitta vid datorn... nu kikar jag bara in lite supersnabbt för att kolla mailen o kollar av mess i forumen jag är med i. :)
Jaa en liten fästis i forumet över installationsmetoder skulle nog hjälpa många nybörjare så de inte avskräcks för att saker är onödigt komplicerat.
Linux har utvecklats till mer användarvänligt sedan 90talet, så vem vet om 10år till, då kanske det finns en installationsstandard som fungerar på alla program o alla linuxversioner. :D
Ingenting är omöjligt, det omöjliga tar bara lite längre tid att genomföra...
Att det blir som det blir, beror på att man gör som man gör, om man inte hade gjort som man gjort, så hade det inte blivit som det blev. ;)
Marie SWE
Ninja
 
Inlägg: 194
Blev medlem: tor mar 01, 2018 12:39 am

Re: Sökte, men hittade inget om installera .tar.gz2

Inläggav Marie SWE » tis aug 21, 2018 2:44 pm

Jan-Olof skrev:
Marie SWE skrev:Går det att skapa ett universalt skript som fungerar i alla mint versioner eller i alla Linux versioner där man bara byter ut namnen i skriptet för att installera olika typer av program som ligger nerpackade i tar.bz2 eller .rar eller .zip...

En god tanke, men att göra någonting allmänt är tyvärr svårt. Om man har källkoden och programmet är välskrivet så är ju det "klassiska" sättet att
* packa upp arkivet
* högerklicka i den nya mappen och öppna ett terminalfönster
* skriva:
Kod: Markera allt
./configure
make
sudo make install

Tyvärr är det ju inte alltid så enkelt. Jag har skript för några program men de går knappast att sätta i händerna på andra. Mycket beror på om utvecklaren verkligen följer gällande standard. Ibland har man stuvat om och lagt någonting på ett helt annat ställe än tidigare. Då fungerar inte skriptet. Sådana problem är vanliga i fråga om program som från början skrivits för Windows.

Ett program som vi tidigare slet mycket hår över var klienten till BankID. Totalt har inläggen om detta lästs nästan 40.000 gånger. Se bland annat viewtopic.php?f=16&t=165

I användarguiden till Mint 16, Petra, fanns ett avsnitt om detta. (Nostalgi-varning! Tag fram näsdukarna.)
https://www.dropbox.com/s/80ih23w422y00 ... 9.pdf?dl=0

Företaget lade sedan ned utvecklingen eftersom "bara" 5.000 personer hade lyckats installera det. Häpnadsväckande, tycker jag. De officiella instruktionerna var så knapphändiga att ingen borde ha klarat det.


Trist att det inte finns en gemensam installationsstandard... man tycker ju att alla som utvecklar Linux vill åt samma håll när typ 80% av linuxanvändare har någon form av förakt mot microsoft.
Men det är ju tyvärr ett standardfenomen med all ideell verksamhet... alla tycker olika och att deras sätt är bäst.. Så det är alltid svårt att få folk mot ett gemensamt mål.. Men det har ju hänt massor på linuxfronten sedan 90talet.. nu kan ju nästan okunniga använda det... så om 10år till så kanske det kommer en standard. :)

Jo jag har hört talas om att bank-id inte fungerar i Linux.. så därför behövs dual boot med windows än så länge... Men de kanske löser bank-id i framtiden.. förhoppningsvis innan 2020 för min del.*hahaha* :lol: :mrgreen:
Ingenting är omöjligt, det omöjliga tar bara lite längre tid att genomföra...
Att det blir som det blir, beror på att man gör som man gör, om man inte hade gjort som man gjort, så hade det inte blivit som det blev. ;)
Marie SWE
Ninja
 
Inlägg: 194
Blev medlem: tor mar 01, 2018 12:39 am

Re: Sökte, men hittade inget om installera .tar.gz2

Inläggav Mikael » tis aug 21, 2018 2:56 pm

Marie SWE skrev:Trist att det inte finns en gemensam installationsstandard...


Visst, men även i Windowsmiljö samt hos Äppelskruttarna finns det ju olika sätt att installera program.
Klen tröst, jag vet, men ändå!
---
Linux Mint 19.3 Tricia, Cinnamon+MATE  @Mintbox Mini2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 1435
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Sökte, men hittade inget om installera .tar.gz2

Inläggav Jan-Olof » tis aug 21, 2018 9:13 pm

Egentligen finns det en bra standard i fråga om programpaket, t.ex. av typen .deb som vi använder. Problemet, som jag ser det, är att en del tillverkare - även kommersiella - inte läser på tillräckligt.
Jan-Olof
Finansiär och Beskyddare
 
Inlägg: 1126
Blev medlem: tis dec 08, 2009 2:07 pm

Re: Sökte, men hittade inget om installera .tar.gz2

Inläggav Marie SWE » tis aug 21, 2018 11:10 pm

Lösningen på problemet... även om det inte är rätt så fungerar det klockrent..
I tipsen från nätet så var de att ladda ner Firefox-59.0.3.tar.bz2 och packa upp den i "home/user/.Mozilla/firefox" låta den skriva över alla filer och att det skulle fungera.

ja det går att starta Firefox59 genom att gå in i mappen "home/user/.Mozilla/firefox" och klicka på firefox
MEN... om man försöker att starta firefox via meny'n eller via firefox ikonen på verktygsfältet, så startade den tidigare installerade versionen av firefox iallafall.

OBS. Detta är ingen lösning på hur man manuellt installerar från tarbollen utan ett sätt att ta sig runt problemet.
Förutom det ovan från nätet, så leta även upp mappen"/usr/lib/firefox/" ersätt de mappar o filer med innehållet från Firefox-59.0.3.tar.bz2

Vips, nu funkar Firefox 59 från alla olika startpossitioner som finns i datorn.. inklusive filer.htm/html som associerar att öppnas med webbläsaren.

Tyvärr hittade jag lösningen när jag redan installerat om Linux mint till version 18.3 Xfce :x 18.3 har firefox57 som standard.

Men en korrekt installationsguide är fortfarande intressant att veta inför framtida bruk. :D

Ha det bästis
Ingenting är omöjligt, det omöjliga tar bara lite längre tid att genomföra...
Att det blir som det blir, beror på att man gör som man gör, om man inte hade gjort som man gjort, så hade det inte blivit som det blev. ;)
Marie SWE
Ninja
 
Inlägg: 194
Blev medlem: tor mar 01, 2018 12:39 am

Föregående

Återgå till Program till Linux Mint

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst

cron