Installera Wine 1.4 i LMDE?

Installera Wine 1.4 i LMDE?

Inläggav Raggos » lör apr 13, 2013 12:27 pm

Hej!
Har försökt att installera Wine 1.4 i paketförådet och även via terminalen enligt nedanstående instruktion men det har inte fungerat, vad gör jag för fel?
Mvh
Raggos

This is the wine64-bin helper package, which does not provide wine itself,
but instead exists solely to provide the following information about
enabling multiarch on your system in order to be able to install and run
the 32-bit wine packages.
The following commands should be issued as root or via sudo in order to
enable multiarch (the last command installs 32-bit wine):
# dpkg --add-architecture i386
# apt-get update
# apt-get install wine-bin:i386
Be very careful as spaces matter above. Note that this package
(wine64-bin) will be removed in the process. For more information on
the multiarch conversion, see: http://wiki.debian.org/Multiarch/HOWTO
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav tux-sven » lör apr 13, 2013 2:24 pm

Jag provade att installera Wine på min 32-bitars-Acer (LMDE). Jag valde Wine i Programhanteraren och tryckte på Install. Installationen funkade klockrent, direkt.
I menyn finns nu åxå Wine Configuration och Wine Uninstaller.
Versionen som installerades var 1.4.1-4.

:roll:
Användarvisningsbild
tux-sven
Ninja
 
Inlägg: 359
Blev medlem: tor nov 19, 2009 9:26 pm
Ort: Götene

Re: Installera Wine 1.4 i LMDE?

Inläggav Jan-Olof » lör apr 13, 2013 11:34 pm

Jag provade just i LMDE Cinnamon 64. Gjorde så här:
Gick via menyn och startade programhanteraren.
Skrev mitt lösenord.
Angav i sökfältet längst upp till höger att jag ville söka efter wine.
Dubbelklickade på namnet (längst upp i träfflistan).
Klickade på Installera-knappen.

Inget mer behövde göras. När installationen var klar så fanns konfigurationsprogrammet för wine i menyn (under Systemverktyg).
Jan-Olof
Finansiär och Beskyddare
 
Inlägg: 1233
Blev medlem: tis dec 08, 2009 2:07 pm

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » sön apr 14, 2013 8:27 am

Det är precis så jag gjort men då har följande text kommit upp i terminalen då programmet inte har visat sig i Cinnamons meny:
This is the wine64-bin helper package, which does not provide wine itself,
but instead exists solely to provide the following information about
enabling multiarch on your system in order to be able to install and run
the 32-bit wine packages.
The following commands should be issued as root or via sudo in order to
enable multiarch (the last command installs 32-bit wine):
# dpkg --add-architecture i386
# apt-get update
# apt-get install wine-bin:i386
Be very careful as spaces matter above. Note that this package
(wine64-bin) will be removed in the process. For more information on
the multiarch conversion, see: http://wiki.debian.org/Multiarch/HOWTO
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav Jan-Olof » mån apr 15, 2013 8:50 am

Någonting måtte ha blivit fel under själva installationen. Du valde väl den första posten i träfflistan, den som bara heter "wine"? Fick du inga felmeddelanden eller varningar när du installerade?

Jag antar att du har provat att använda
sudo apt-get purge wine
och installera på nytt.
Jan-Olof
Finansiär och Beskyddare
 
Inlägg: 1233
Blev medlem: tis dec 08, 2009 2:07 pm

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » mån apr 15, 2013 9:29 am

Jo jag har försökt många gånger men med samma dåliga resultat. (inga varningar har visats) Om nedanstående problem har nått samband har jag funderat över. Programvarulagret pekar mot "debian latest". Som ex så pekar raden till ffmulticonverter fel men när jag ändrade den i mappen sources.list.d till samma rad som i ubuntu 12.04 fungerade det att installera programmmet :D


Misslyckades med att hämta http://debian.lth.se/lmde/latest/dists/ ... /InRelease Unable to find expected entry 'non/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)
Misslyckades med att hämta http://ppa.launchpad.net/ffmulticonvert ... ce/Sources 404 Not Found
Misslyckades med att hämta http://ppa.launchpad.net/ffmulticonvert ... 4/Packages 404 Not Found
Misslyckades med att hämta http://ppa.launchpad.net/ffmulticonvert ... 6/Packages 404 Not Found
Misslyckades med att hämta http://packages.linuxmint.com/debian/di ... 4/Packages 404 Not Found
Misslyckades med att hämta http://packages.linuxmint.com/debian/di ... 4/Packages 404 Not Found
Misslyckades med att hämta http://packages.linuxmint.com/debian/di ... 4/Packages 404 Not Found
Misslyckades med att hämta http://packages.linuxmint.com/debian/di ... 6/Packages 404 Not Found
Misslyckades med att hämta http://packages.linuxmint.com/debian/di ... 6/Packages 404 Not Found
Misslyckades med att hämta http://packages.linuxmint.com/debian/di ... 6/Packages 404 Not Found
Some index files failed to download. They have been ignored, or old ones used instead.
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav tux-sven » mån apr 15, 2013 10:31 am

Dessa källor är original i min 32-bitars-version:

Sources1.png
Sources1.png (49.16 KiB) Visad 4131 gånger


Sources.png
Sources.png (42.47 KiB) Visad 4127 gånger
Användarvisningsbild
tux-sven
Ninja
 
Inlägg: 359
Blev medlem: tor nov 19, 2009 9:26 pm
Ort: Götene

Re: Installera Wine 1.4 i LMDE?

Inläggav Mikael » mån apr 15, 2013 10:56 am

Raggos skrev:Jo jag har försökt många gånger men med samma dåliga resultat. (inga varningar har visats) Om nedanstående problem har nått samband har jag funderat över. Programvarulagret pekar mot "debian latest". Som ex så pekar raden till ffmulticonverter fel men när jag ändrade den i mappen sources.list.d till samma rad som i ubuntu 12.04 fungerade det att installera programmmet :D
Misslyckades med att hämta http://debian.lth.se/lmde/latest/dists/ ... /InRelease Unable to find expected entry 'non/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)
osv.....
Some index files failed to download. They have been ignored, or old ones used instead.


Den här typen av fel har jag stött på några gånger. Tycker det verkar som att "man" stänger servern för hämtning när det är dags för uppdateringar, där.
Felet har alltså inte varit i min ände utan på serversidan.
---
Linux Mint 19.3 Tricia, Cinnamon @Mintbox Mini2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 1752
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » mån apr 15, 2013 3:34 pm

Min sources.list ser ut så här, det som är lite märkligt är att den rätta koden till ffmulticonverter hamnade i mappen sources.list.d, kan tycka att den borde hamnat i filen sources.list. De felaktiga raderna till programmet finns inte i sources.list men syns I programvarukällor>other software där två rader till ffmulticonverterer felaktiga. Raden till Spotify hamnade vad jag förstår på rätt ställe.

deb http://debian.lth.se/lmde/latest testing main contrib non free
deb http://debian.lth.se/lmde/latest/multimedia testing main non-free
deb http://debian.lth.se/lmde/latest/security testing/updates main contrib non-free
deb http://packages.linuxmint.com/debian main upstream import backport
deb http://packages.linuxmint.com/debian main upstream import
deb http://mirror.tuxis.nl/packages/ debian main upstream import backport

deb http://repository.spotify.com stable non-free
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » tis apr 16, 2013 7:59 am

Efter ominstallation är det mu rätt rader även i programvarukällor>other software där två rader tidigare var felaktiga till ffmulticonverter.
Om jag istället väljer förrådet "incoming testing" så visas inga felmedelanden :mrgreen:
En tanke, skulle det gå att installera wine 1.4 som är avsed för Ubuntu?
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav Jan-Olof » tis apr 16, 2013 11:52 am

Har du efter ominstallationen provat att använda det vanliga paketförrådet? När jag provade så fungerade det ju - jag fick den senaste stabila versionen, precis som Sven.
Jan-Olof
Finansiär och Beskyddare
 
Inlägg: 1233
Blev medlem: tis dec 08, 2009 2:07 pm

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » tis apr 16, 2013 4:11 pm

Ber om ursäkt! Med ominstallation syftade jag på ffmulticonverter då en del av raden "ubuntu debian" fick bytas ut mot "ubuntu precise". Efter några uppdateringar står det åter "ubuntu debian" men programet funkar så det kanske inte hade någon betydelse.
Provade med att installera Wine från Ubuntus förråd men det fortsätter att strula som synes nedan.


** Debian / Wine: Multiarch Instructions **

This is the wine64-bin helper package, which does not provide wine itself,
but instead exists solely to provide the following information about
enabling multiarch on your system in order to be able to install and run
the 32-bit wine packages.

The following commands should be issued as root or via sudo in order to
enable multiarch (the last command installs 32-bit wine):

# dpkg --add-architecture i386
# apt-get update
# apt-get install wine-bin:i386

Be very careful as spaces matter above. Note that this package
(wine64-bin) will be removed in the process. For more information on
the multiarch conversion, see: http://wiki.debian.org/Multiarch/HOWTO

(okay)
debianmint:~$ dpkg --add-architecture i386
dpkg: fel: kunde inte skapa ny fil "/var/lib/dpkg/arch-new": Åtkomst nekas
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav Mikael » tis apr 16, 2013 9:55 pm

Åtkomst nekas

Rättigheter? Köra som root?
kanske
sudo dpkg --add-architecture i386
funkar?
---
Linux Mint 19.3 Tricia, Cinnamon @Mintbox Mini2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 1752
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » ons apr 17, 2013 10:38 am

Har försökt med det också men det funkar inte heller :( Övriga program har det inte varit några problem med!
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Re: Installera Wine 1.4 i LMDE?

Inläggav Raggos » ons apr 17, 2013 11:09 am

Kan tillägga att komandot nedan inte verkar fungera, wine64-bin finns kvar, inget wine-bin:i386 syns till fast jag använt sudo :(
Mikael skrev:sudo dpkg --add-architecture i386
Raggos
Samuraj
 
Inlägg: 94
Blev medlem: lör jun 11, 2011 8:18 am

Nästa

Återgå till Program till Linux Mint

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 2 gäster