[löst] Får inte xbindkeys att fungera

[löst] Får inte xbindkeys att fungera

Inläggav Mikael » mån jun 11, 2018 10:47 pm

Här en direktlänk som beskriver vad jag vill kunna göra:
http://xahlee.info/linux/linux_set_F2_F ... paste.html

Får det inte att fungera och exemplet ser inte ut som hur filen ser ut efter att ha använt xbindkeys-config.

Jag kan få funktionstangenterna att göra annat, som att starta caja om jag som "command" anger just caja
Men varken kopiera eller klistra in fungerar..
Vad gör jag för fel tro?
Visar hur min fil ser ut med några kommandon som fungerar:
Kod: Markera allt
###########################
# xbindkeys configuration #
###########################
#
# Version: 0.1.3
#
# If you edit this, do not forget to uncomment any lines that you change.
# The pound(#) symbol may be used anywhere for comments.
#
# A list of keys is in /usr/include/X11/keysym.h and in
# /usr/include/X11/keysymdef.h
# The XK_ is not needed.
#
# List of modifier (on my keyboard):
#   Control, Shift, Mod1 (Alt), Mod2 (NumLock),
#   Mod3 (CapsLock), Mod4, Mod5 (Scroll).
#
# Another way to specifie a key is to use 'xev' and set the
# keycode with c:nnn or the modifier with m:nnn where nnn is
# the keycode or the state returned by xev
#
# This file is created by xbindkey_config
# The structure is :
# # Remark
# "command"
# m:xxx + c:xxx
# Shift+...




#keystate_numlock = enable
#keystate_scrolllock = enable
#keystate_capslock = enable



#Kopiera
"caja"
    m:0x10 + c:67
    Mod2 + F1

#Klistra
"krusader"
    m:0x10 + c:70
    Mod2 + F4

#
# End of xbindkeys configuration
Senast redigerad av Mikael tor jun 14, 2018 6:45 pm, redigerad totalt 1 gång.
---
Linux Mint 20 Ulyana, Cinnamon @Mintbox Mini2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 1850
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker

Re: Får inte xbindkeys att fungera

Inläggav Mikael » tor jun 14, 2018 6:20 pm

Efter en hel del trixande har jag hittat en lösning.
Skapade två skripfiler, kopiera.sh och klistrain.sh
Kod: Markera allt
#! /bin/bash
xvkbd -no-jump-pointer -xsendevent -text '\Cc'

respektve
Kod: Markera allt
#! /bin/bash
xvkbd -no-jump-pointer -xsendevent -text '\Cv'


I xbindkeys-config har jag som action /home/mint/Skriptfiler/kopiera.sh respektive /home/mint/Skriptfiler/klistrain.sh

Detta tycks fungera i webbläsaren men inte i textredigeraren xed, av någon anledning...
Tillägg: Funkar i Leafpad.
---
Linux Mint 20 Ulyana, Cinnamon @Mintbox Mini2 Pro      "from freedom came elegance"
Mikael
Finansiär och Beskyddare
 
Inlägg: 1850
Blev medlem: lör jan 07, 2012 3:29 pm
Ort: Söråker


Återgå till Övriga supportfrågor

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 3 gäster

cron