Ljudet delvis borta i Mint 11 LÖST

Ljudet delvis borta i Mint 11 LÖST

Inläggav Mintgrön » sön okt 09, 2011 10:34 pm

Sinnesförvirring: ursprungligen stod här DivX när jag borde ha skrivit DirectX
Ljudet försvann
Dator/system: Amilo L1300 Linux Mint 11

Installerade Google Earth. Programmet ville använda DirectX i stf OpenGL. Jag sa ja men Earth föreslår fortfarande övergång till DirectX (OM visar renderare=OpenGL, videodrivrutin=Mesa Project). Efter det försvann ljudet för vissa tillämpningar.

Inget ljud (i Firefox 7.0.1 for Linux Mint ver 1.0)
- Youtube
- Play Rapport (STV)
- Grooveshark

Ljudet fungerar i
- Skype
- Banshee
- när jag dubbelklickar på en Mp3-fil; ljud i Totem 2.32.0/GStreamer 0.10.32
- drar mp3-fil till Firefox (se ovan)
- drar mp3-fil till Epiphany webbläsare 2.30.6
- spelar mp3-fil i VLC

Jag tolkar detta som att ljudkortet fortfarande fungerar och att jag stökat till det i mjukvaran.

Jag har inte hittat någon hjälp på nätet. Det jag funnit går för djupt tycker jag och jag är rädd att stöka till det ännu mer. Jag bifogar ett utdrag om vad som sitter på moderkortet. Före åtgärden för Google Earth så fungerade ljudet borde jag väl tillägga.

sudo lspci -v
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICHesa Project). Efter det försvann ljudet för vissa tillämpningar.

Inget ljud (i Firefox 7.0.14-M) AC'97 Audio Controller (rev 03)
Subsystem: Fujitsu Technology Solutions Device 1079
Flags: bus master, medium devsel, latency 0, IRQ 5
I/O ports at e100 [size=256]
I/O ports at e200 [size=64]
Memory at f0080400 (32-bit, non-prefetchable) [size=512]
Memory at f0080600 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2
Kernel driver in use: Intel ICH
Kernel modules: snd-intel8x0
Senast redigerad av Mintgrön ons nov 02, 2011 10:29 pm, redigerad totalt 2 gånger.
Mintgrön
Munk
 
Inlägg: 13
Blev medlem: mån jun 20, 2011 12:17 pm

Re: Ljudet delvis borta i Mint 11

Inläggav Jan-Olof » mån okt 10, 2011 8:21 am

Vilken version har du? Jag har 6.0.2.2074 och den fungerar normalt. Kan inte påminna mig att jag fick någon fråga om DivX.

Vad händer om du avinstallerar programmet och sedan installerar på nytt?
Jan-Olof
Finansiär och Beskyddare
 
Inlägg: 1152
Blev medlem: tis dec 08, 2009 2:07 pm

Re: Ljudet delvis borta i Mint 11

Inläggav tux-sven » mån okt 10, 2011 7:18 pm

Jag kör åxå GoogleEarth 6.0.2.2074-r0-1mint2, fast i LMDE. Funkar helt OK, känner inte igen att jag fått nå'n fråga heller.

Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
Användarvisningsbild
tux-sven
Ninja
 
Inlägg: 359
Blev medlem: tor nov 19, 2009 9:26 pm
Ort: Götene

Re: Ljudet delvis borta i Mint 11

Inläggav Mintgrön » mån okt 10, 2011 10:41 pm

Jag kör samma version av Google Earth, se bifogad bild. Vad står det för renderare resp videodrivare för era installationer?

Google Earth fungerar som förväntat även om det går långsamt. Det är i andra tillämpningar som format med ljud och/eller video inte hanteras korrekt.

Grön i Mint är förvisso korrekt. Jag vet inte hur man avinstallerar ett program. Kan ni ge mig en anvisning var jag lättvindigt kan inhämta kunskapen? Jag stapplar mig fram än så länge.


google_earth_om.png
Google Earth Alternativ Om
google_earth_om.png (17.33 KiB) Visad 3793 gånger
Mintgrön
Munk
 
Inlägg: 13
Blev medlem: mån jun 20, 2011 12:17 pm

Re: Ljudet delvis borta i Mint 11

Inläggav tux-sven » tis okt 11, 2011 9:27 am

jag antar att du installerade GoogleEarth via "Mintinstall" eller "Programhanteraren" som det heter på svenska. Där kan du åxå avistallera programmet.
Eller åxå högerklickar du på GoogleEarth-ikonen i den vanliga program-menyn, så ser du ett val att avinstallera.
Det finns ytterligare sätt att att göra det på, men jag tror dessa är enklast.

-------------------------------------------------
Google Earth 6.0.2.2074
Build-datum 10-3-2011
Build-tid 20:45:09
Renderare OpenGL
Operativsystem Linux (3.0.0.0)
Videodrivrutin Tungsten Graphics, Inc
Största strukturstorlek 2048x2048
Server kh.google.com
-----------------------------------------------

/Sven
Användarvisningsbild
tux-sven
Ninja
 
Inlägg: 359
Blev medlem: tor nov 19, 2009 9:26 pm
Ort: Götene

Re: Ljudet delvis borta i Mint 11

Inläggav Jan-Olof » tis okt 11, 2011 10:25 am

...och jag har (i Katya-64)

Google Earth 6.0.2.2074
Build-datum 10-3-2011
Build-tid 20:45:09
Renderare OpenGL
Operativsystem Linux (2.6.38.0)
Videodrivrutin Tungsten Graphics, Inc
Största strukturstorlek 4096x4096
Server kh.google.com
Jan-Olof
Finansiär och Beskyddare
 
Inlägg: 1152
Blev medlem: tis dec 08, 2009 2:07 pm

Re: Ljudet delvis borta i Mint 11

Inläggav Mintgrön » ons okt 12, 2011 2:34 pm

Tack för tipsen om avinstallation! Er information är samma som jag har fast jag kör en 32-bitars version på en 32-bitars dator.

Högerklick på programmet lyckades inte, se bild nedan. Meddelandet om saknat paket kom upp men sedan hände inget. Programikon i Menyn låg kvar och Earth startade snällt när man klickade på genvägen.

dpkg_query_saknas_avinst_gearth.png
Saknat paket
dpkg_query_saknas_avinst_gearth.png (17.61 KiB) Visad 3776 gånger


I Programhanteraren stod programmet fortfarande som installerat med ta bort-knapp. Tredje gången gillt! Visseligen inget meddelande om att åtgärden lyckats eller gått till slut men programikonen fanns inte längre i Menyn och kvarglömt ikon i panelen sade att filerna inte fanns kvar.

Ljudet har emellertid inte kommit tillbaka. Tips om fler systemprogram som underlättar felsökningen?
Mintgrön
Munk
 
Inlägg: 13
Blev medlem: mån jun 20, 2011 12:17 pm

Re: Ljudet delvis borta i Mint 11

Inläggav tux-sven » ons okt 12, 2011 9:41 pm

OK det är kanske läge att öppna ett terminalfönster och köra från kommandoraden? ;)
apt-get är ett kommando som har olika optioner för att det skall utföra olika saker.
Man behöver vara root för att kunna installera och avinstallera program, så börja alltid med "sudo"
EX: Installera en fil -> apt-get install [filnamn]
Avinstallera en fil ->apt-get remove [filnamn]
Uppdatera listan med installerbara filer -> apt-get update.
Exempelvis, ta bort GoogleEarth:
Kod: Markera allt
sudo apt-get remove googleearth

Installera GoogleEarth på nytt:
Kod: Markera allt
sudo apt-get update
sudo apt-get install googleearth

För att se vilka övriga möjligheter som finns med apt-get, öppna ett termialfönser och skriv:
Kod: Markera allt
apt-get --help

/Sven
Användarvisningsbild
tux-sven
Ninja
 
Inlägg: 359
Blev medlem: tor nov 19, 2009 9:26 pm
Ort: Götene

Re: Ljudet delvis borta i Mint 11

Inläggav Mintgrön » ons nov 02, 2011 5:04 pm

Tack för informationen, tuxsven!

Vilken lättnad när man blir lotsad direkt till ett verktyg! Att läsa manualer är en sak men att förstå vad som bör väljas bland alla alternativ/kommandon kräver mer.

Jag har ser 2 alternativ för hantering av program i Meny. Under System har jag Programhanterare (mintinstall 7.3.3) och Pakethhanterare (Synaptic 0.70). Jag har (troligen) använt Programhanteraren vid installaton/avinstallation då den inte kräver så mycket kunskap.

I Synaptic under Status-fliken alternativet Inte installerade (Kvarlämnad installation) hittar jag Googleearth.

Jag följde dina instruktioner beträffande apt-get. Remove gav upphov till ett påpekande att det fanns fler beroenden installerade men som inte tagits bort. Jag ignorerade/utförde inte auto. Vad får det för konsekvenser?

Före installationen av GoogleEarth igen installerade jag Audacity som ett deperat hopp men ljudet var fortfarande borta.

Installation av GoogleEarth lyckades men ljudet från Grooveshark via Firefox saknades fortfarande (jag sade nej till DirectX denna gång). Vad göra?

Jag chansade och klickade på högtalaren i meddelandefältet och fick upp Ljudinställningar, som visade fliken Program med ALSA plug in (plugin-container (vadför något?)) Klick på ikonen gav ljud i högtalarna! Hurra!! Men vad har jag gjort?

Hur markerar jag att detta inlägg är avslutat? Jag ser ingen sådan knapp.
Mintgrön
Munk
 
Inlägg: 13
Blev medlem: mån jun 20, 2011 12:17 pm

Re: Ljudet delvis borta i Mint 11

Inläggav tux-sven » ons nov 02, 2011 6:01 pm

Alsa är ett ljud och mixersystem i Linux. Jag tror att det du gjorde var helt korrekt! :lol:

Alsa har en central roll i ljud-sammanhanget och du aktiverade tydligen ett paket med alsa-program.

För att visa att ärendet är löst så öppnar du tråden med "Ändra", därefter kan du t.o.m. korrigera rubriken, d.v.s. exempelvis lägga till "[LÖST]" eller "*LÖST*" efter rubriknamnet. (utan citationstecken förstås) :D
Användarvisningsbild
tux-sven
Ninja
 
Inlägg: 359
Blev medlem: tor nov 19, 2009 9:26 pm
Ort: Götene


Återgå till Övriga supportfrågor

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 1 gäst